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ETH Course 402-0248-00L: Electronics 
for Physicists II (Digital)

• 1: Setup uC tools, introduction

• 2: Solder SMD AVR32 board

• 3: Build application around AVR32 

• 4: Design your own PCB schematic

• 5: Place and route your PCB. Fabricate your 
PCB at a production house

• 6: Start logic design with FPGAs

Printed Circuit Board (PCB) design tools

Pros Cons Cost

Eagle 
(cadsoft)

Free (simple boards)
Easy to learn
Truly cross platform

Clunky interface
Limited router

Free for 
limited 
version.  
345 EUR for 
full version 
if student.

Altium Powerful Windows only 3k CHF
Or 300/yr
ETH

Cadence Really powerful Arcane
(l)unix only

$$$ except 
ETH has 
license 
seats
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Keith Barret’s introduction to Eagle

Introducing Eagle PCB
by Keith Barrett - Pakuranga College, Auckland, New Zealand  electronics@pakuranga.school.nz

1.0 December 2002

mailto:electronics@pakuranga.school.nz
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Eagle costs

EAGLE Light (1 schematic sheet, 2 
signal layers, 100x80mm 
routing area)

Free for Educational 
purpose

EAGLE Standard (99 schematic sheets, 6 
signal layers, 160x100mm 
routing area)

http://www.cadsoftusa.co
m/shop/pricing/

EAGLE Hobbyist (99 schematic sheets, 6 
signal layers, 160x100mm 
routing area; for 
individual, non 
commercial use only)

http://www.cadsoftusa.co
m/shop/pricing/

EAGLE Professional (999 schematic sheets, 16 
signal layers, 4m x 4m 
routing area)

http://www.cadsoftusa.co
m/shop/pricing/

Eagle Title Screen 

This is the control panel screen 
which should appear when the 
programme opens.

http://www.cadsoftusa.com/shop/pricing/
http://www.cadsoft.de/shop/eagle-hobbyist-and-education/
http://www.cadsoftusa.com/shop/pricing/
http://www.cadsoftusa.com/shop/pricing/
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Eagle Control Panel

Directory tree. . .
To begin with only focus upon 

the  LIBRARIES and PROJECTS 

directories

Eagle PCB Libraries

Click here to display 

the LIBRARIES
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Libraries

These folders contain the data used to 
generate the symbols for the diagrams. 
They contain schematic pinout data for 
individual components and package 
layout diagrams used on the pcb layout

These buttons allow you to select 
and de-select files.

Libraries - example

This file type contains  schematic pinout 
data

This file type contains standard  package 
layout diagrams used on the pcb layout.

File content descriptions
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Libraries - Schematic

Click on a schematic file

Symbol used in schematic 
diagrams

Lists of types sizes 
and shapes!

Libraries - Packages

Click on a package file

Symbol used in PCB 
(component layout) diagrams

Component  Information 

(Reference and dimensions)
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Eagle PCB Projects

Click here to display 

the PROJECTS

Projects

The Projects folders are where you 
place your work.

When creating a design there are 
two main types of file which are 
generated by the programme

.sch (Circuit schematic designs) 
and .brd (pcb layout boards)
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Schematics
The schematic 
window allows the 
design of circuits like 
this flip-flop using 
standard component 
symbols

From this point the 
pcb can be created on 
the “board” screen

Boards
This is a board 
produced from the 
previous schematic. . 
.

The software 
automatically 
generated the 
symbols and pathways 
from the schematic.

All positioning, 
track widths and 
pad sizes can be 
changed by the 
user.
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First Steps with Eagle PCB
by Keith Barrett - Pakuranga College, Auckland, New Zealand  electronics@pakuranga.school.nz

v 1.0 December 2002

First Steps with Eagle PCB?

This is the second presentation and will show 

you how to produce a simple circuit 

schematic diagram using this software.

mailto:electronics@pakuranga.school.nz
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Creating a Project 

Run the Eagle program, when the 

control panel window appears click on 

File > New > Project

Creating a Project 2 

Clicking new project opens a 
new folder in the projects 
section. 

You may want to rename the project at 
this point.

The green button shows that this is the 

currently selected project
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Creating a Project 3

Next click on

File > New > Schematic

Creating a Project 4

The file and viewing tools are along the top

The selection and editing tools are here

The drawing tools are here.

Roll the cursor over the icons to see the function labels. A 

brief desciption of each function will appear here.

On this screen 

you create the 

circuit schematic 

diagram. . . . . 
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Creating a Project 6
Next click on “add” to open the library window.

Then click on “rcl” to open this 
component library.

Creating a Project 7

Double Click to select this component (1/2 watt 
resistor 9mm long 10mm spacing)

Click to open this component library 
(resistors- european)

This symbol will appear on the 
schematic screen. Place it by clicking the 
mouse.
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Creating a Project 8

This is what   the screen should look like  (you may have to zoom in to 
get it this size!)

Having placed the first component you need to get a few more. Click 

on the add icon each time to open the library and choose 

a few more. . .try finding a 9V battery and an led.

The delete icon is here if you need to remove objects.

Creating a Project 9

Move the components around the screen using this (move) key.

You can edit the labels here
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Creating a Project 10

“Wire”  the components together using this key. click the mouse to 
start, change direction and double click (or esc) to finish a connection.

Creating a Project 11

Place “junctions”  where wires meet the components. 

When you have a complete circuit SAVE it!
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Making library components

This is the 3rd presentation and will show you 
how to make a new library component

It follows from the excellent Eagle tutorial at 
http://myhome.spu.edu/bolding/EE4211/EagleTutor
ial4.htm

http://myhome.spu.edu/bolding/EE4211/EagleTutorial4.htm
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Atmel hosts a massive number of user-
contributed libraries

• For example, if you search at cadsoft for 
“atmel” the first items are interesting to us:

Caution: you get what you pay for….

What’s in a library?

• Open an existing library
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Each library contains three types of elements:

1. Symbols - These are the symbols that show up on a 
schematic. An inverter symbol is an example.
– Click the Symbol tool (from the top menu) and choose 7404 

to see the inverter symbol.

2. Packages - These are the package outlines that will be used 
to make a PCB. A 14-pin DIL (Dual In-Line package) is an 
example. 
– Click the Package tool and select DIL14 to see the DIL14 

package.

3. Devices - Devices are groups of symbols that exist in a 
package. For example a 7404 hex inverter is an example. It 
consists of six inverters, power and ground pins and 
contains a link to several packages including a 14-pin DIL 
package. 
– Click the Device tool and select 7404 to see the 7404 hex 

inverter package.

Making symbol from scratch: Gizmogate

1. Make new library

2. Create new symbol          giving name

3. Draw the symbol, using Text tool for 
text 

1. Put >NAME on Names layer using 
Change tool         selecting layer, and 
choosing Names and then clicking on 
>NAME. 

2. Do same for >VALUE but put on Values
layer.

3. They should turn gray.

4. These will be filled in in your design
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1. Now add input and output 
pin using Pin tool

2. Use Change tool to select 
direction of pin

3. Name the pin with Name tool

4. Use the pin style to select the 
style, etc.

5. Save the library

To copy a symbol from a library
1. In the existing library, use Edit 

Symbol tool to choose the part
2. Make all layers visible with Layers 

button and selecting All
3. Make a group with the Group tool 

by dragging around everything
4. Select Cut to copy to clipboard
5. Open your library and make your 

new part. Paste the copy using 
Paste tool.

6. Change as you like using Change 
tool
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Making a package from scratch

1. Select Package, enter name DIL-8

2. Select Grid tool and select grid 0.025 with 
multiple of 2

3. For through hole parts, you need holes in 
right place and large enough! (Common 
error, holes too small!) Use the Hole tool, 
place pads CCW from bottom left.

4. For SMD, use the SMD Pad tool

5. Draw the outline on layer tPlace.

Place >NAME and >VALUE on part

1. Put >NAME on tName layer

2. Put >VALUE on tValue layer

3. Add pin 1&8 labels

You’re done with DIL-8 part. Save 
your library
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Putting symbols and packages together

The final task in making a part is to create 
a device that has information on how symbols 
are placed inside of a package. For many 
devices, there will be only one 
symbol. However, many devices contain 
multiple symbols, as well as hidden power pins.

1. Make a new device with the Device 
button. Enter the name.

2. Add N copies of symbol, depending 
on number of gates in device.

3. Change names using Names tool.
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ETH Course 402-0248-00L: Electronics 
for Physicists II (Digital)

• 1: Setup uC tools, introduction

• 2: Solder SMD AVR32 board

• 3: Build application around AVR32 

• 4: Design your own PCB schematic

• 5: Place and route your PCB. Fabricate your 
PCB at a production house

• 6: Start logic design with FPGAs

Making Eagle pcbs
by Keith Barrett - Pakuranga College, Auckland, New Zealand  electronics@pakuranga.school.nz

v 1.0 December 2002

mailto:electronics@pakuranga.school.nz
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Making Eagle PCBs?

This is the 4th presentation and will show you 

how to produce a simple, single layer printed 

circuit board from a circuit schematic diagram 

using this software.

Loading the Schematic 

Run the Eagle program, 

when the control panel 

window appears click on 

File > Open >Project

. . then find the project 

folder containing your 

schematic.

You can double click here or here to open the folder. Both actions will load the file for 

the schematic (and board file if you have already created one)
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Creating a Project 2 

When the schematic has 
loaded select 

File > Switch to board

The software will then check to see if a board file exists to go 
with schematic.  If it does it will load the file, otherwise it will 
offer to create one automatically.

select yes

Creating a board 1
This is the component layout generated by the program.

components & “wires”    Board working area

Use the move tool to drag each 

component onto this area – (this is 

what will print)
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Creating a board 
2

Components can be 
rotated as well as 
repositioned click on the centre of the symbol to 

rotate by 90⁰

The next stage is to create the tracks using “autoroute”

Creating a board 
3

Clicking here generates an options menu. . . 

If you are only using single-sided pcbs 
then set the top layer to N/A

. . . then click OK
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Creating a board 
4

Autoroute then turns the “wires” into track pathways. . . 

Crea
ting 

a 
boar
d 5

To change the track width, 
select     change > width 

. . .then select the dimension (these are in inches 
– units can be set in mm)

point at the track and right click.
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Creating a board 
6

To add text  select the text tool

enter text in the box and 
place on the diagram

Text is automatically inverted if the “bottom 
layer” is chosen

Creating a board 
7

Choose the layers to print select View > Display/hide
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Creating a board 
8

Here you can select 
what appears on 
screen and the 
printer. (blue = selected / 

white = deselected)

Click on the numbers to turn 
on/off. Click on the colour to edit 
the colour scheme

For most single sided pcbs 
everything should be off except 
layers 16,17 (tracks & pads) 45 
(drill holes)

Save and print your board.

End of presentation 3 

http://www.pakuranga.school.nz/depart/electronics/eaglepcb
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ETH Course 402-0248-00L: Electronics 
for Physicists II (Digital)

• 1: Setup uC tools, introduction

• 2: Solder SMD AVR32 board

• 3: Build application around AVR32 

• 4: Design your own PCB schematic

• 5: Place and route your PCB. Fabricate your 
PCB at a production house

• 6: Start logic design with FPGAs

How do you get your PCB fabricated?

1. Have your own PCB router/driller machine.

– Starts with blank PCB covered with metal, mills 
away all metal and places plugs for vias.

2. Or, send your board design away for 
fabrication
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Example of having board fabricated

• You need to know 

1. Board dimensions in mm x mm

2. Number of layers

3. Basic rules such as min track width and spacing, 
minimum hole size

http://www.pcb-pool.com/ppuk/order_productconfiguration_js.html

http://www.pcb-pool.com/ppuk/order_productconfiguration_js.html
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Ball Grid Array (BGA)

You can solder 
these parts using 
a reflow oven

Soldering BGA yourself in reflow oven
1. Apply thin layer of flux (not solder paste) to board.
2. Carefully place BGA part using your alignment marks (drawn on metal, 

not silkscreen!).
3. Reflow part in oven.
4. Visually check from all sides with microscope.

PadsAlignment mark
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Reflow oven

• Applies temperature profile to slowly heat 
parts to avoid stress and allow volatile gases 
to escape, activates flux, then reflows solder

• Hint: Use gold finish on pads if you ever want 
to rework boards because gold does not 
oxidize

Beta Layout reflow oven plus controller
200 EUR – oven plus controller.


